Shield Security Minimum System Requirements

We try to ensure that Shield Security is compatible with, and runs reliably on, as many systems as possible, while keeping the code and performance optimal for all clients.

If you've been directed here from the Shield plugin, it's probably because your current WordPress or PHP versions are older than an upcoming change in minimum requirements.

Please use the details below to determine whether your hosting environment is compatible with the latest version of Shield Security and any upcoming releases. If your PHP is out-of-date, we urge you to contact your WordPress hosting provider to see what options are available for upgrading and testing the upgrade.

Version 19.0+ [Due Late 2023]

  • Minimum PHP: 7.4
  • Minimum WordPress: 5.7
  • Minimum MySQL: 5.6

Version 18.2+ [Released July 2023]

  • Minimum PHP: 7.2
  • Minimum WordPress: 5.7
  • Minimum MySQL: 5.6

Version 17.0+ [Released February 2023]

  • Minimum PHP: 7.2
  • Minimum WordPress: 4.9
  • Minimum MySQL: 5.6

Version 12.0+ [Released September 2021]

  • Minimum PHP: 7.0
  • Minimum WordPress: 3.7
  • Minimum MySQL: 5.6 (for native support for IPv6 address handling)

Version 10.0+

  • Minimum PHP: 7.0
  • Minimum WordPress: 3.7
  • Minimum MySQL: 5.5

Version 6.0+

  • Minimum PHP: 5.4
  • Minimum WordPress: 3.7
  • Minimum MySQL: 5.5

Version 1.0+

  • Minimum PHP: 5.2
  • Minimum WordPress: 3.5
  • Minimum MySQL: 5.5